В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
gspd000
gspd000
04.01.2020 08:31 •  Информатика

Написать программу: найти количество элементов в массиве при любом n,в записи которых есть число три

Ответ:
Nesty111111
Nesty111111
19.08.2020 14:26
//Pascal ABC.NET v3.1 сборка 1172

Const
 n=5;

Var
 ar:array[1..n] of integer;
 ars:array[1..n] of string;
 i,k:integer;
begin
 for i:=1 to n do
  begin
   readln(ar[i]);
   str(ar[i],ars[i]);
   if pos('3',ars[i])<>0 then inc(k);
  end;
 write('Res=',k);
end.

Пример ввода:
135
246
357
468
579
Пример вывода:
Res=2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?