В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
almaziksky311
almaziksky311
23.09.2021 20:27 •  Информатика

Синформатикой ,10 класс. : напишите программу вычисления суммы всех элементов массива.проверьте работу программы на заданном массиве a={7,25,4.5,0,17,61,-10,0,1,-4,22}

Ответ:
DarthVader111103
DarthVader111103
27.05.2020 23:20

var a:array[1..10000] of real;

  i,n:integer;s:real;

begin

  readln(n);

  s:=0;

  for i:=1 to n do

  begin

     read(a[i]);

     s:=s+a[i];

  end;

  writeln;

  write('s=',s);

end.

Проверяем решение

вводим n=11

затем вводим элементы массива 7,25,4.5,0,17,61,-10,0,1,-4,22

получаем ответ s=123.5

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?