Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ladykati
02.06.2021 06:48 •
Информатика
Составить программу вычисления среднего арифметического элементов с четными номерами. массив состоит из n элементов заданных с клавиатуры
Ответ:
AliceKrauch
03.10.2020 09:05
Program qq;
const N=(количество чисел в массиве);
var A:array[1..N] of integer;
i, S,k,SA:integer;
begin
for i:=1 to N do readln(A[i]);
S=0; SA:=0; k:=0;
for i:=0 to N do
if (imod2=0) then begin
S=S+A[i];
k:=k+1;
end;
SA:=S/k;
writeln(sa);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
moiseenkova041
18.04.2023 06:47
Гис и гис-технологии это одно и то же?...
птимзшктвіал
04.01.2021 23:29
Составить алгоритм управления Чертёжником, в результате которого на координатной плоскости будет нарисован квадрат, длина стороны которого равна 9 единицам. Алгоритм:...
ilgam2000
13.02.2022 15:46
Минформатикой , язык с++. может кто решал уже или сможет . : знайка и незнайка играют в такую игру: знайка называет незнайке число, а незнайка перемножает все цифры...
Пиирмвп
13.02.2022 15:46
№3 представить ниже числа в виде вещественных констант без экспонент. 4)7.46д1 и объясните, , что такое д1...
Диана8909
13.02.2022 15:46
Для какого минимального натурального числа а, логическое выражение ¬(x делится на 39) → ((x делится на 3) → ¬(x де- лится на тождественно истинно (то есть принимает...
PashaPlaytri
22.10.2022 03:01
Построить график функции y=sin x + cos xна интервале [-3,14;3,14] с шагом 0,2. Строим аналогично примеру 1. Таблица строится из 2 столбцов: аргумент х, функция y...
varyavernerr
20.05.2020 03:51
1.На слайд можна додавати:декілька відповідейа)текстові поляб)таблиців)зображенняг)відеод)звуке)диски2.Обрати правильні вимоги до презентації:декілька відповідейа)Відсутність...
cadatik04
16.08.2022 11:23
До іть будь ласка з 10-11-12...
lera10u
01.01.2022 17:54
Почему появлению письменности дало толчек развитию науки и культуры...
sherilblo
30.11.2022 12:06
Маленький житель волшебного острова сделал себе одежду из листьев деревьев . 65 из них -листья дуба ,это на 20 листьев больше ,чем берёзы ,и на 15 листьев меньше...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
const N=(количество чисел в массиве);
var A:array[1..N] of integer;
i, S,k,SA:integer;
begin
for i:=1 to N do readln(A[i]);
S=0; SA:=0; k:=0;
for i:=0 to N do
if (imod2=0) then begin
S=S+A[i];
k:=k+1;
end;
SA:=S/k;
writeln(sa);
end.