Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
grugoryan85
24.10.2022 00:29 •
Информатика
Найти все элементы, большие среднего арифметического элемента в массиве s(8)
Ответ:
alenalapshna2
03.10.2020 09:14
Program qq;;
var S:array[1..8] of integer;
i, SA, sum, k:integer;
begin
for i:=1 to N do readln(S[i]);
sum=0; k:=0; SA:=0;
for i:=0 to 8 do begin
sum:=sum+A[i];
k:=k+1;
end;
SA:=s/k;
if (S[i]>SA) then writeln(S[i]);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
k0tesss
24.10.2020 19:12
Применение 5Составьте алгоритмы.1. «Пирожки». Асхат купил в столовой пирожок. Не наен-шись одним пирожком, он купил еще один.2. «Перевод». Нужно перевести слова с английского...
kwjeps
27.12.2022 03:48
Вводится последовательность из n целых чисел. найти среднее арифметическое его цифр (функцией оформить определение среднего арифметического цифр числа). (c#)...
darabajkova4770
27.12.2022 03:48
Определить номер наибольшего элемента массива a и наибольшего значения среди модулей элементов массива a. составить программу в паскале. массив одномерный и значений...
katakoval
16.01.2022 02:46
Вклассе 30 учеников. сколько в классе может быть девочек и сколько мальчиков, если известно, что (девочек не меньше, чем мальчиков) и (мальчиков не меньше, чем 14)?...
chcuvivhcyxu
25.02.2023 17:06
Информатика нужно выбрать правильный ответ...
RassvetZaGorami
01.07.2022 19:30
2. Что выполняют фрагменты программ: 1. nFor i:=1 to 10 do readln(A[i]); 2. nFor i:=1 to 10 do A[i]:=random(1000)-500; 3. nFor i:=1 to 10 do writeln(A[i]); 4. nFor...
thedesxte
05.08.2021 11:15
Завдання 1: Скласти програму друку таблиці значень функції y = sinx для х є[0,1] з кроком 0,1 Задание 1: Составить программу печати таблицы значений функции y = sinx...
бракус11
17.04.2023 12:35
Переведи число 30448 в десятичную систему счисления....
Yana6hhhh
06.09.2022 21:19
с информатикой, одно задание никак не получается.Схема дорог.Приложил фотку....
STAS228917654321
07.07.2021 03:21
Что такое руБИ отмечу как лучший ответ = правильный ответ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var S:array[1..8] of integer;
i, SA, sum, k:integer;
begin
for i:=1 to N do readln(S[i]);
sum=0; k:=0; SA:=0;
for i:=0 to 8 do begin
sum:=sum+A[i];
k:=k+1;
end;
SA:=s/k;
if (S[i]>SA) then writeln(S[i]);
end.