В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
supervoron
supervoron
05.06.2023 11:48 •  Информатика

Напишите программу со алгоритмами запрашивающую количество элементов линейного массива действительных чисел не более 50 затем сам массив затем выводящую на экран полученный массив и на следующей строке номер последнего из его отрицательных элементов

Ответ:
JIuchno
JIuchno
03.10.2020 08:50
Ну, значит, как-то так:

program arrays;
type
myArr = array of integer;
var
arr : myArr;
neg : integer;
i, n : integer;

begin
write('Введите размер массива: ');
readln(n);
if n>50 then n:=50;
setLength(arr, n);
randomize;
neg :=0;
for i:=0 to n-1 do begin
arr[i]:=random(200)-100;
if arr[i]<0 then neg:=arr[i];
write(arr[i], ' ');
end;
writeln;
writeln ('Последний отрицательный элемент массива: ', neg);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?