В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
agnesa9890
agnesa9890
28.10.2021 03:42 •  Информатика

Написать программу на паскале дана строка текста,знаков препинания в строке нет.напечатать все слова,заканчивающиеся на "ов" с функции pos

Ответ:
Sidor209
Sidor209
03.10.2020 08:41
//Pascal ABC.NET v3.1 сборка 1172

Var
 s:string;
 i:integer;
begin
 readln(s);
 var wo:=s.ToWords(s);
 for i:=0 to length(wo)-1 do
 begin;
 delete(wo[i],pos(' ',wo[i]),1);
 if (pos('ов',wo[i])=length(wo[i])-1) then writeln(wo[i]);
 end;
end.

Пример ввода:
Иов Петров Петрон Человек
Пример вывода:
Иов
Петров
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?