В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
denis181203
denis181203
26.06.2022 16:58 •  Информатика

Написать программу для паскаля. даны координаты вершин треугольника авс. найти его площадь.

Ответ:
Vikaadamm
Vikaadamm
07.06.2020 04:45

program Triangle;

 

var X1,X2,X3,Y1,Y2,Y3: real;

   p, a, b, c: real;

 

begin

   Writeln('Введите координаты точек (X1,Y1), (X2,Y2), (X3,Y3):');

   ReadLn(X1, Y1, X2, Y2, X3, Y3);

   a: = Dlina(X1-X2,Y1-Y2);

   b := Dlina(X1-X3,Y1-Y3);

   c := Dlina(X2-X3,Y2-Y3);

   p := (a+b+c)/2;

   WriteLn('Площадь равна ', sqrt(p*(p-a)*(p-b)*(p-c)));

end;

 

fucntion Dlina(var x,y:real):real;

begin

  Dlina := sqrt(x*x+y*y);

end.

0,0(0 оценок)
Ответ:
Vыдыhaй1235
Vыдыhaй1235
07.06.2020 04:45

var
a:real;
b:real;
c:real;
x1,x2,x3:integer;
y1,y2,y3:integer;
p:real;
s:real;
begin
writeln('первые координаты треугольника x ');
readln(x1);
writeln('вторые координаты треугольгика x ');
readln(x2);
writeln('третьи координаты треугольгика x ');
readln(x3);
writeln('четвертые координаты треугольгика y ');
readln(y1);
writeln('пятые координаты треугольгика y ');
readln(y2);
writeln('шестые координаты треугольгика y ');
readln(y3);
a:=sqrt(x2-x1)+ (y2-y1);
b:=sqrt(x3-x2)+(y3-y2);
c:=sqrt(x3-x1)+(y3-y1);
p:=a+b+c;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('Периметр = ',p:2:0);
writeln('Площадь=',s:1:2);
readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?