В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tatyana101035
tatyana101035
31.08.2020 17:59 •  Информатика

Составьте программу которая найдет три последние цифры произведения 1*2**18

Ответ:
PomogyBratan
PomogyBratan
03.10.2020 08:32
Программу можно и не составлять (среди сомножителей есть 2, 5, 10, 12, 15 и, следовательно произведение будет оканчиваться на 3 нуля).
Если нужно найти не 3, а 4 последние цифры, то программа может быть такой:
var i,p:integer;
begin
p:=1;
for i:=1 to 18 do p:=p*i mod 10000;
writeln(p);
end.

Результат:
8000

А если вместо mod 10000 написать mod 1000, то:
Результат:
0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?