В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
slovendim
slovendim
30.11.2020 00:00 •  Информатика

Напишите программу в паскале, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 4. количество чисел не превышает 1000. введенные числа не превышают 30 000. программа должна вывести одно число — максимальное число, кратное 4.

Ответ:
Classica27725
Classica27725
07.09.2020 16:58
Program zadacha;
var n, x, i, max: integer;
begin
max:=0;
Writeln ('Введите количество чисел');
Readln (n);
for i:=1 to n do begin
readln (x);
if (x mod 4=0) and (x>max) then max:=x;
end;
writeln (max)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?