В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Fin208
Fin208
07.07.2022 20:41 •  Информатика

Впаскале составить программу даны 3 числа если среди них больше чётных то числа удвойте иначе прибавить к числам 1

Ответ:
DedMazaj
DedMazaj
22.09.2020 18:35
Const N = 3;
var a: array[1..N] of integer;
i, x: integer;
begin
x:=0;
for i:=1 to N do begin
read(a[i]);
if a[i] mod 2 = 0 then
x:=x+1;
end;
if 2*x >= N then
for i:=1 to N do begin
a[i]:=a[i]*2;
writeln(a[i]);
end
else
for i:=1 to N do begin
a[i]:=a[i]+1;
writeln(a[i]);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?