Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
lilytrap
19.09.2021 13:59 •
Информатика
Pascal abc, нужно решить через while дано целое число n (> 0). найти сумму n2 + (n + 1)2 + (n + 2)2 + (целое число).
Ответ:
Josoy
22.09.2020 13:59
Var
n, i, s: integer;
begin
readln(n);
s := 2 * n;
i := 1;
while i <= n do
begin
s := s + 2 * (n + i);
i := i + 1;
end;
writeln(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
chemist69
30.03.2020 15:12
Вмассиве состоящего из n элементов подсчитать количество положительных элементов больших чем k- вводится с клавиатуры. массив вводится случайным образом на [0; 20]. паскаль! ....
daniilkornev05
30.03.2020 15:12
1)одна страница книжки прочитывается за н минут, в книжке s страниц. за сколько часов книжка будет прочитана? 2)составите программу вычисления площади, периметра и длины диагоналей...
QbQbQb
18.02.2023 00:20
Я отправила фото учителю в Вайбер с неправильным решением, можно ли сделать фото как-нибудь недоступным (не удаляя его, так как если я его удалю, училка заметит). Если да, то как?...
ксюша1704
01.04.2022 00:36
Файли яких типів можна створювати з використанням онлайн-редакторів Gооgle?...
lusine20041904
10.04.2020 04:37
Как сделать фото в Вайбер недоступным, не удаляя его?...
shhfxecbhawc
13.04.2021 07:55
Дано положительное число a.найдите среди чисел 1,1+1/2,1+1/,большее a.. написать программу в паскаль...
домашка68
03.06.2020 06:30
Сочинение ,, жили-были клавиатура, монитор, память и процессор. жили они дружно, пока не возник спор , кто из них главные....
Ршмшрмпширщ
28.06.2021 00:48
Какие сущесвуют устройс ва ввода информации...
kutirev123p
10.12.2020 15:43
Законы логики ! a*b*c+a*! b*c+a*b*! c+a*b*c=...
FairTail
08.03.2023 18:19
Cтереофайл с частотой дискретизации 48 кгц и глубиной кодирования 24 бита преобразовали в монофайл с частотой дискритизации 24 кгц и глубиной кодирования 16 бит.во сколько раз исходный...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n, i, s: integer;
begin
readln(n);
s := 2 * n;
i := 1;
while i <= n do
begin
s := s + 2 * (n + i);
i := i + 1;
end;
writeln(s);
end.