В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
efrdariya14
efrdariya14
21.07.2022 11:51 •  Информатика

Решить с 3-х циклов: 1) "для"; 2) "пока"; 3) "до" составить программу подсчета суммы нечетных делителей, кратных трем, натурального числа n.

Ответ:
katy247
katy247
03.10.2020 07:54
1)
var 
i, d, c: integer;
begin
c:=0;
readln(d);
for i:=1 to d do
If (i mod 3 = 0) and (i mod 2<>0) and (d mod i = 0) then 
c:=c+i;
writeln(c);
end.

2)
var 
i, d, c: integer;
begin
i:=0;
c:=0;
readln(d);
while i<=d do
If (i mod 3 = 0) and (i mod 2<>0) and (d mod i = 0) then begin
c:=c+i;
i:=i+1;
end;
writeln(c);
end.

3)
var i, d, c: integer;
begin
i:=0;
c:=0;
readln(d);
repeat
If (i mod 3 = 0) and (i mod 2<>0) and (d mod i = 0) then begin
c:=c+i;
i:=i+1;
end;
until i<d;
writeln(c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?