В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nacny2016
nacny2016
09.04.2020 13:23 •  Информатика

Составьте программу которая выводит на экран из всех трёхзначных чисел, только те у которых квадрат первой цифры равен сумме двух остальных.

Ответ:
Маалинка1
Маалинка1
03.10.2020 07:49
Var
i: integer;
begin
for i:=100 to 999 do
if (sqr(i div 100) = i mod 10 + i div 10 mod 10) then
writeln(i);
end.
0,0(0 оценок)
Ответ:
Naruto1111111111
Naruto1111111111
03.10.2020 07:49
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  for var i:=100 to 999 do begin
    var d1:=i div 100;
    var d2:=(i div 10) mod 10;
    var d3:=i mod 10;
    if sqr(d1)=d2+d3 then Print(i)
    end;
  Println
end.

Тестовое решение:
101 110 204 213 222 231 240 309 318 327 336 345 354 363 372 381 390 479 488 497
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?