В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
даша2149
даша2149
20.05.2020 03:04 •  Информатика

Напишите программу которая вычисляет сумму 1) первыз n натуральных чисел 2) квадратов первых n натуральных чисел 3) всех четных чисел в диапазоне от 1до n 4) всех двузначных чисел

Ответ:
NastyuZnanija
NastyuZnanija
03.10.2020 07:46
// PascalABC.NET
var i,n,s1,s2,s3,s4:integer;
begin
  readln(n);
  for i:=1 to n do begin
    s1:=s1+i;
    s2:=s2+i*i;
    if i mod 2=0 then s3:=s3+i;
    if (i>9) and (i<100) then s4:=s4+i;
  end;
  writeln(s1,' ',s2,' ',s3,' ',s4)

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?