В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
annaarzama
annaarzama
05.03.2023 22:26 •  Информатика

Составить программу вычисления сумму цифр трех значнного числа

Ответ:
SIBGATULLINA98
SIBGATULLINA98
03.10.2020 07:47
Program _1;

var x,a,b,c,s:integer;

begin

write('Введите исходное число');
readln(x);
a:=x div 100;
b:=x mod 100 div 10;
c:=x mod 10;
s:=a+b+c;
writeln('s=',s)
end.
0,0(0 оценок)
Ответ:
alexaste
alexaste
03.10.2020 07:47
Вот два варианта: с переводом числа в строку, и без. но здесь для 4х-значных чисел. по аналогии можно сделать и для 3х-значных. блин, фотки не прикрепились...
Составить программу вычисления сумму цифр трех значнного числа
Составить программу вычисления сумму цифр трех значнного числа
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?