Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
stupidgirl3
28.07.2021 19:06 •
Информатика
Pascal.abc дано случайное количество чисел, узнать сколько совершенных чисел в этом ряду (написать программу).
Ответ:
lushnikov2004
07.09.2020 16:20
Var i, k, n, a, sum, kol: Integer;
Begin
readln(n);
kol := 0;
for k := 1 to n do begin
sum := 0;
read(a);
for i := 1 to a-1 do
if a mod i = 0 then sum := sum + i;
if sum = a then kol := kol + 1;
end;
writeln(kol);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
Lizzzzxff
28.04.2020 03:28
При вводе текста придерживайся следующих правил: 1)там где нужно использовать прописные буквы(Shift + Буква);2)не следит за концом строки: как только он будет достигнут,курсор...
роги1
19.10.2021 14:34
Проверочная работа «Линейные алгоритмы» Часть 1 1. Оператор присваивания имеет вид: а) = б) := в) =: г) Верного ответа нет. 2. Целочисленное деление можно выразить следующей...
sunksy
03.02.2022 16:12
Вася составляет 5-буквенные слова, в которых есть только буквы С, И, Р, О, П, причём в каждом слове обязательно есть ровно одна буква О, при этом стоять она может только после...
Gufka965
18.09.2021 18:53
Скласти речення зі словами овочевий салат, крайовничий музей, софіїна книжка...
nikita030303b
23.07.2021 18:27
Найти промежутки множетилей ф-ции у=-(x-7)^2 +3...
юсик17
26.12.2021 04:15
Вv веке до н.э. персы начали завоевательные походы в грецию, множество страшных битв произошло в это время. укажите битвы, которые относятся к греко-персидским войнам. битва...
Albuss
24.04.2020 21:35
Уменя есть пес дружок. мне 11 лет, псу 2 месяца. сколько лет будет мне через 3 года? сколько лет будет псу через 1год 12 месяцев? ...
AlinkaMalinka233
15.07.2022 20:52
Умоляю 50 ,не вру ,честно говорю.только решите,умоляю.надо построить график функции...
Лессикаа
23.07.2022 05:32
Арефметическая прогрессия решите между числами -10 и 2 вставьте таки два числа чтобы все 4 числа сделали растущую арифметическую прогрессию . найдите 14-й член этой прогресии...
миёк2
08.11.2022 22:22
Написать уравнение и краткую запись не забудьте....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Begin
readln(n);
kol := 0;
for k := 1 to n do begin
sum := 0;
read(a);
for i := 1 to a-1 do
if a mod i = 0 then sum := sum + i;
if sum = a then kol := kol + 1;
end;
writeln(kol);
End.