В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Много 1. написать программу, которая заполняет массив с клавиатуры целыми числами и распечатывает его элементы в обратном порядке. массив описывается через константу n. для проверки взять n=5. то есть выводится a[5], a[4],…,a[1]. пример выполнения программы: входные данные выходные данные 2 3 6 4 8 --> 8 4 6 3 2 2. написать программу, которая выводит на печать каждый третий элемент массива (или те элементы, индекс которых кратен 3). массив описывается через константу n. для проверки взять n=10. пример выполнения программы: входные данные выходные данные 1 2 3 4 5 6 7 8 9 10--> 3 6 9

Ответ:
amadi888
amadi888
03.10.2020 07:38
1.
const n=5;
var
a: array[1..n] of integer;
i: integer;
begin
for i:=1 to n do
read(a[i]);
for i:=n downto 1 do
write(a[i], ' ');
end.

2.
const n=10;
var
a: array[1..n] of integer;
i: integer;
begin
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if i mod 3 = 0 then
write(a[i], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?