В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vladimirshmele1
vladimirshmele1
08.07.2021 13:32 •  Информатика

Разработать схему алгоритма и написать программу a) вычисления среднего арифметического четырех чисел; b) вывода вашего роста , возраста и веса на экран4 c) вычисление значения корней квадратного уравнения выполнить трассировку программ.

Ответ:
Рафаэлла2004
Рафаэлла2004
03.10.2020 07:28
1.
var
a, b, c, d: integer;
sr: real;
begin
readln(a, b, c, d);
sr := (a+b+c+d)/4;
writeln(sr);
end.

2. 
begin
writeln('Рост: 181');
writeln('Вес: 81');
writeln('Возраст: 28');
end.

3. 
var
a, b, c, d: integer;
x1, x2: real;
begin
readln(a, b, c);
d := b*b-4*a*c;
if d > 0 then
begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
writeln(x1, ' ', x2);
end;
if d < 0 then
begin
x1:=-b/(2*a);
writeln(x1);
end;
if d > 0 then
writeln('Корней нет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?