В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MoonRiad
MoonRiad
11.08.2020 00:31 •  Информатика

Написать программу на с++ даны три стороны одного и три стороны другого треуголь- ника. эти треугольники равновеликие, т.е. имеют равные площади.

Ответ:
Razzey
Razzey
03.10.2020 07:22
#include <iostream>
#include <cmath>
using namespace std;
double eps = 0.000001;
double sq(double a, double b, double c)
{
   double p = (a + b + c) / 2;
   return sqrt(p * (p - a) * (p - b) * (p - c));
}
int main() 
{
   double a1, b1, c1, a2, b2, c2;
   cin >> a1 >> b1 >> c1 >> a2 >> b2 >> c2;
   if (sq(a1, b1, c1) >= sq(a2, b2, c2) - eps && sq(a1, b1, c1) <= sq(a2, b2, c2) + eps)
      cout << "YES";
   else
      cout << "NO";
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?