Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ruchev06
19.04.2020 03:05 •
Информатика
Составить программу, подсчитывающую сумму вводимых с клавиатуры чисел ,если количество чисел заранее неизвестно, но известно, что последнее число равно 0 !
Ответ:
postnovat
03.10.2020 07:25
Var
s, x: integer;
begin
s:=0;
repeat
readln(x);
inc(s, x);
until x = 0;
writeln(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
shaplen
25.10.2020 04:22
Примеры иерархических систем в окружающем мире...
Neimeyumozg
21.03.2023 10:22
это ПаскальПеременной a присвоено значение 5. Установите соответствие:Write(‘a’) 1) 5 Write(a) 2) aWrite(‘a=’, a) 3) a=5...
Варенье11333333
15.08.2020 18:56
Условный оператор: if (x 2) thеn y:= x+7 else y:= x — 21.Выбери действие, которое будет выполняться в случае истинности условия:y:= x+7х 2у: =х — 21...
kri2221
28.01.2021 09:47
Выберите возможные IPадреса: 1. 149.169.206.272 2. 175.149.202.270 3. 170.173.204.287 4. 186.168.202.132 5. 165.149.206.263 6. 118.161.203.133...
skiba04
28.01.2021 09:47
Аблоылтол о иллих поащтвдлся мгоалаоился ромб э...
imverypanda228
15.05.2023 07:18
ББОооТТ зЗНннАаННИИи тТТееЛЛЕеаАмМ - @united brai nly (бБЕз пПрРбБбеЕлЛЛОоВВ)...
Софалия
30.07.2022 03:37
БооОтТ зЗЗННААННнииИЯЯ тТелЛЕЕЕггРаамМ - @united brai nly (бееЗЗ РррбБЛоВвВ)...
Ivan4554
22.03.2023 06:48
2. Пользователь работал с каталогом C:\Документы\Договоры\Продажа. Сначала он поднялся на один уровень вверх, затем спустился в каталог , затем спустился в каталог Покупка. Укажите...
sandraustaow6o7c
15.03.2022 04:13
Информатика 9 класс Массивы в Pascal...
5Vlad2851
08.10.2021 04:50
БоОоТт ззнАаНннИи ТееЕЛЛЛеГГграАМм - @united brai nly (бееЗЗз ППпРроООБББЕеЛовв)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
s, x: integer;
begin
s:=0;
repeat
readln(x);
inc(s, x);
until x = 0;
writeln(s);
end.