В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MariaUralova
MariaUralova
04.06.2021 16:00 •  Информатика

Составить программу, вычисляющую факториал числа n. (n! = 1·2·3·…·n) 3 цикла

Ответ:
hcjdbghfgyfjfh
hcjdbghfgyfjfh
21.09.2020 23:25
//Pascal ABC.NET v3.0 сборка 1111

//for
Var
 i,n,r:integer;
begin
 readln(n);
 r:=1;
 for i:=1 to n do
  r:=r*i;
 write(r);
end.

//while

Var
 i,n,r:integer;
begin
 readln(n);
 r:=1;
 i:=0;
 while i<>n do
  begin;
   inc(i);
   r:=r*i;
  end;
 write(r);
end.

//repeat
Var
 i,n,r:integer;
begin
 readln(n);
 r:=1;
 i:=0;
 repeat
   inc(i);
   r:=r*i;
 until n=i;
 write(r);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?