В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
BAMBELBI013
BAMBELBI013
04.12.2020 08:28 •  Информатика

Напишите программу, которая вводит с клавиатуры 10 реальных чисел, и организовывает их хранение в массиве. после этого массив пересор- тировывается по закону: первый элемент меняется с последним

Ответ:
maksim2657
maksim2657
21.09.2020 23:24
//реальные числа - странное определение чисел вещественного типа
//Pascal ABC.NET v3.0 сборка 1111

Var
  ar:array[1..10] of real;
 i:integer;
 k:real;
begin
 writeln('Array:');
  for i:=1 to 10 do
   readln(ar[i]);
  k:=ar[1];
  ar[1]:=ar[10];
  ar[10]:=k;
 writeln('Final array:');
 for i:=1 to 10 do
 write(ar[i]:4);
end.

Пример ввода:
1
2
..
10
Пример вывода:
Final array:
  10   2   3   4   5   6   7   8   9   1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?