В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dick666
Dick666
18.08.2020 19:59 •  Информатика

Devc++ . даны три целых числа a, b и с напишите программу, которая находит количество всех целых чисел от a до b, которые при целочисленном делении на с дадут остаток больший 4 входные данные: в первой строке вводятся три целых числа a, b и с (a< =b, a,b не больше 100 по модулю, 0< =с< =9) выходные данные: программа должна вывести одно число - количество всех целых чисел от a до b, которые при целочисленном делении на с дадут остаток больший 4 пример: ввод 1 10 9 вывод: 4 выполните с #include conio.h и #include stdio.h

Ответ:
Онелик
Онелик
21.09.2020 22:39
#include <iostream>
#include <conio.h>
#include <stdio.h>

int main(int argc, char** argv) {
int a,b,c,k = 0; 
scanf("%d",&a); 
scanf("%d",&b); 
scanf("%d",&c);  
for (int i=a;i<=b;i++)    
{           
 if(i%c>4) k++;
}    
printf("/%10d/",k);
system ("pause");
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?