В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Krupenyapolina
Krupenyapolina
19.01.2023 02:22 •  Информатика

Нужно написать программу в "паскале" для перевода из любых систем исчисления в десятичную.

Ответ:
oksakuvp01cde
oksakuvp01cde
21.09.2020 21:57
Var
  n, k, i: integer;
  s: string;
begin
  write('Введите число: ');
  read(s);
  write('Введите исходную систему счисления: ');
  read(k);
  for i := 1 to length(s) do
    n := n * k + ord(s[i]) - 48;
  write(s, '(2) = ', n, '(10)');
end.

Пример работы программы:
Введите число: 101000111000111
Введите исходную систему счисления: 2
101000111000111(2) = 20935(10)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?