Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Maqa11
03.12.2021 21:10 •
Информатика
1. задан массив d. определить следующие суммы: d[1] + d[2] + d[3]; d[3] +d[4] +d[5]; d[4] + d[5] + d[6], используя подпрограмму для вычисления суммы трех последовательно расположенных элементов массива.
Ответ:
vorontsovaksus
03.10.2020 06:40
#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#include <functional>
#include <cstring>
#include <utility>
#include <bitset>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <cstdio>
#include <climits>typedef unsigned long long ulol;
typedef long long lol;
typedef long int li;#define mp make_pair
#define F first
#define S second
#define sqr(a) ( (a) * (a) )
#define pb push_back
#define INF 999999999
#define ret(a) cout << endl; system("pause"); return(a)
//#define ret(a) return(a)using namespace std;int main()
{
lol n;
cin >> n;
vector<lol> ar(n);
for(int i = 0 ; i < n ; i ++)
cin >> ar[i];
for(int i = 0 ; i < n ; i += 3)
cout << i+1 << '-' << i+3 << ": " << ar[i]+ar[i+1]+ar[i+2] << endl;
ret(0);
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Kirill0812
01.08.2021 06:56
1.Значення списку можна скопіювати в незалежний новий список за до одного з наступних ів функції copy() функції list() функції list[] функції copy{} розділенням списку за...
ира8800
19.12.2022 23:37
1.Значення списку можна скопіювати в незалежний новий список за до одного з наступних ів функції copy() функції list() функції list[] функції copy{} розділенням списку за...
TOLIK474747
19.06.2022 22:03
Ниже записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа a и b. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 5,...
xXMaRoXx
10.09.2020 23:08
у кого есть Scratch 2 Надо сделать алгоритм 1.во Должен говорить ПРАВИЛЬНО 2.если 2+2=другой ответ. . . То неправильно 3 когда закончит поменять фон и профи дальше И так еще...
Elino4kaK
04.06.2021 12:29
Какие из операторов цикла существуют С++?...
илья1949
22.11.2021 17:06
Какой результат даст выражение НАДО...
krylovadashenk
11.01.2022 04:10
Вшкольной лотерее 80 билетов,из них 20 выигрышных. какова вероятность проигрыша...
Bashirov12
11.01.2022 04:10
Температура воздуха на земле постоянно повышается за 100 лет почти на полградуса. на сколько градусов повысится температура за 1000 лет....
cmpunk559
11.01.2022 04:10
Стороны четырёхугольника авсd, ab, bc, cd, da стягивают дуги 70⁰, 75⁰, 117⁰, 157⁰. найти уогл в этого чтырёхуогльника в градусах....
Nik23218
11.01.2022 04:10
Персей боги принемавшиие участие в судьбе персея...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <sstream>
#include <fstream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#include <functional>
#include <cstring>
#include <utility>
#include <bitset>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <cstdio>
#include <climits>typedef unsigned long long ulol;
typedef long long lol;
typedef long int li;#define mp make_pair
#define F first
#define S second
#define sqr(a) ( (a) * (a) )
#define pb push_back
#define INF 999999999
#define ret(a) cout << endl; system("pause"); return(a)
//#define ret(a) return(a)using namespace std;int main()
{
lol n;
cin >> n;
vector<lol> ar(n);
for(int i = 0 ; i < n ; i ++)
cin >> ar[i];
for(int i = 0 ; i < n ; i += 3)
cout << i+1 << '-' << i+3 << ": " << ar[i]+ar[i+1]+ar[i+2] << endl;
ret(0);
}