В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alinayusupova305
alinayusupova305
11.01.2020 06:03 •  Информатика

Python. 70 . решить с циклов. 1) найдите все пятизначные числа, которые при делении на 133 в остатке 125, а при делении на 134 в остатке 111. 2)натуральное число называется числом армстронга, если сумма цифр числа, возведенных в n-ную степень (где n – количество цифр в числе) равна самому числу. например, 153 = 13 + 53 + 33. найдите все трёхзначные армстронга. 3)натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. например, 252 = 625. напишите программу, которая получает натуральное число n и выводит на экран все автоморфные числа, не превосходящие n.

Ответ:
Бота157
Бота157
03.10.2020 06:21
#задание 1
for i in range(10000,100000):
    if ((i % 133 == 125) & (i % 134 == 111)):
         print(i)

#задание 2
s=0
for i in range(100,1000):
    n=i
    while (n>0):
        s+=pow(n % 10,3)
        n=n // 10
    if (s==i):
        print(i)
    s=0

#задание 3
n=int(input('задайте N: '))
for i in range(1,n):
    d=10
    while (i>=d):
        d=d*10 
   if ((i*i % d)==i):
        print('число ',i,'квадрат ',i*i) 
       
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?