В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
valentina05ru
valentina05ru
03.12.2020 06:36 •  Информатика

Составить программу которая формирует массив из16 элементов случайных чисел от -20 до 20 и находит элементы с нулевыми значениями

Ответ:
Rimmakrasa
Rimmakrasa
23.05.2020 18:39

Program g;
Var
A, B : Integer;
N : Integer;
S : Integer;
z:array[0..16] of integer;
i : Integer;
v:integer;
Begin
A:=(-20);
B:=20 ;
N:=16 ;
For i := 1 To N Do
Begin
S := Trunc(Random(B-A)+A);
WriteLn (i:2,'-е случайное число:',S:4);
End;
begin
writeln('Індексы элементов кратных 3:');
for v:=0 to 16 do begin
z[v]:=random(40)-20;
if z[v] mod 3 = 0 then write(v, ' ')
end;
end;
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?