В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
natalyabelozer3
natalyabelozer3
26.02.2020 01:31 •  Информатика

Как написать программу для pascal abc которая считает факториал числа который вводит пользователь

Ответ:
tanyushalyubim
tanyushalyubim
21.09.2020 16:57
//Pascal ABC.NET v3.0 сборка 1111
//Обойдусь без .Net-овских примочек

var
 a,b,i:integer;
begin
 readln(a);
 if a=0 then
  begin;
   writeln('1');
   exit;
  end;
  if a<0 then
   begin;
    writeln('Не определён');
    exit;
  end;
 b:=1;
 for i:=1 to a do
 b:=b*i;
 writeln('Res=',b);
end.

Пример ввода:
3
Пример вывода:
6
0,0(0 оценок)
Ответ:
olga2610
olga2610
21.09.2020 16:57
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var n:=ReadInteger('n=');
  if n<0 then Writeln(n,'! не определено: n<0')
  else
    if n=0 then Writeln('0!=1')
    else begin
      var p:BigInteger:=1;
      for var i:=2 to n do p*=i;
      Writeln(n,'!=',p)
      end
end.

Тестовое решение:
n= 138
138!=691778647261948849222819828311491035886734385827028118707676848307166514238979223884785249055995983385450621636277440066920043595627074569065446040152660143904127838730788278294186615891819670506731208704000000000000000000000000000000000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?