В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mklslajh
mklslajh
20.07.2020 13:45 •  Информатика

Составьте в паскаль с while. на каждом следующем дне рождения винни пух съедает столько же меда, сколько съел на двух предыдущих вместе. на двух первых днях рождения у пятачка и кролика он съел по 100 г меда. определите, сколько килограммов меда он съест на десятом дне рождения.

Ответ:
Nikodim39
Nikodim39
07.09.2020 13:49
Числа Фибоначчи (вместо 1 только 100)!
var m1,m2,s,i:integer;
begin
m1:=100; m2:=100;
for i:=3 to 10 do
 begin
 s:=m1+m2;
 m1:=m2;
 m2:=s;
 end;
writeln(s);
end.

Результат:
5500
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?