В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
hamster321123
hamster321123
20.07.2020 13:45 •  Информатика

Составьте программу в паскаль с while. у малыша к банок варенья. в первый день карлсон съел одну банку, в каждый последующий день съедая в 1,5 раза больше, чем в предыдущий. через сколько дней варенье кончится?

Ответ:
kassndra8137
kassndra8137
30.08.2020 19:23
Var K, den, s_el: real;
Begin
Writeln('Введите K банок');
readln(K);
s_el:=1;
K:=K - s_el;
den:=1;

While (K>0) do
Begin
    s_el:= s_el * 1.5;
    K:=K - s_el;
    den:=den+1;
 end;

Writeln('Варенье кончится через ', den, ' дней');

readln();
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?