В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Аліна23456
Аліна23456
03.01.2020 20:05 •  Информатика

Написать программу нахождения суммы всех чисел> заданного к при вводе до первого отрицательного.

Ответ:
ilonazin03
ilonazin03
21.09.2020 16:22
//Pascal ABC.NET v3.0 сборка 1111

var
 a,k,s:integer;
begin
readln(k); //вводим k
a:=0;
s:=0;
 while a>=0 do //пока а >=0
  begin;
   if a>k then s:=s+a; //если a>k, тогда добавляем к s
   readln(a); //каждый раз вводим в a
  end;
writeln(s); //выводим s
end.

Пример ввода:
45
34
56
67
-2
Пример вывода:
123
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?