В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zrice
zrice
25.03.2022 14:57 •  Информатика

Написать программу на паскале абс цикл с постусловием дано целое число n (> 1). вывести наименьшее из целых чисел k, для которых сумма 1 + 2 + … + k будет больше или равна n, и саму эту сумму.

Ответ:
vika27072
vika27072
03.10.2020 06:12
Var n,k,summ:integer;
begin
  write('Введи число N: ');
  readln(n);
  repeat begin
     k:=k+1;
     summ:=summ+k;
     end;
  until summ>=n;
  writeln('K=',k,', 1+..+',k,'=',summ,', ',summ,'>=',N);
end.  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?