Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Вероникапривет
08.05.2023 17:52 •
Информатика
Составить программу возведения натурального числа в квадрат, используя следующую закономерность: i2 =1 2 2=1+3 з2 =1 + 3 + 5 42=1+3+5+7 п2 = 1 + 3 + 5 + 7 + 9 + . . + 2 п - 1 программа pascal
Ответ:
kerikan
25.08.2020 09:19
Всё до безобразия просто:
var n:integer; nn:real;
begin
write('Введи число: ');
readln(n);
for var i:=1 to n do nn:=nn+(2*i-1);
writeln(n,'^2=',nn);
end.
0,0
(0 оценок)
Ответ:
MrLech
25.08.2020 09:19
Function MySQR(n : Integer) : Integer;
Begin
If n>1 then MySQR:=n+MySQR(n-2) else MySQR:=1;
end;
Var a : Integer;
Begin
Readln(a);
Writeln(MySQR(a*2-1));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
avamini2007
02.07.2022 09:15
Решите плеаз(((( последние отдал...
Beleklera75
25.01.2022 13:53
Задание Напишите программу, которая бы выполняла перевод единиц измерения. За основу можете взять код, приведенный в уроке. В программе должны быть: 1. Ввод значения...
дияр22
15.05.2021 14:41
Двоичная арифметика ( умножение) 11101*11111= ) и с проверкой если можно заранее )...
ChristenChy
15.05.2021 14:41
Вывести квадраты и кубы 10 чисел следущей последовательности: 1, 2, 4, 7, 11, 16.....
FireStreamGun
19.04.2021 19:05
18+3x^2-x=0. решить это уравнение. знакомая объяснила как решить всё равно не получается.1) напишите где а где б где с? именно буквы и цифры? 2 напишите формулу)...
Falkon5511
02.07.2022 23:46
Казахский язык четвёртый класс 75 страница номер четыре номер пять...
иляяя1яяя
22.05.2021 02:47
Какое число нужно уменьшить в 3 раза,чтобы получить 23? б)во сколько раз нужно увеличить 9,чтобы получить 63.записать уровнения и решить их...
Травка58
14.02.2021 15:24
Выписать слова с пропущенными буквами и объяснить написание.(можно объединять одинаковые ! , чуть н. каждый день анфиса ходила в город.кую библиотеку менять книги....
catikis
24.09.2022 05:12
Какая масса осадка выпадает при взаимодействии 60г пятипроцентного (5%) раствора карбоната натрия с хлоридом натрия. ...
Lapka298
09.06.2021 22:24
1)в прямоугольном параллелепипеде стороны основания равны 2 м и √5м,а высота равна 3 м.выполните чертеж и найдите: а) диагональ прямоугольного параллелепипедаб) угол...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var n:integer; nn:real;
begin
write('Введи число: ');
readln(n);
for var i:=1 to n do nn:=nn+(2*i-1);
writeln(n,'^2=',nn);
end.
Begin
If n>1 then MySQR:=n+MySQR(n-2) else MySQR:=1;
end;
Var a : Integer;
Begin
Readln(a);
Writeln(MySQR(a*2-1));
end.