В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
leger13245
leger13245
02.08.2022 02:19 •  Информатика

Составьте программу, которая определяет к какой группе относится введенный символ (с) – к цифрам, заглавным или прописным буквам. на экран должна выводиться фраза «символ с – это …», где вместо … пишется соответствующая группа (например, «символ r – это заглавная буква»).

Ответ:
mariyalesnyak
mariyalesnyak
13.08.2020 18:24
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var c:=ReadlnChar('Введите символ');
  case c of
  'A'..'Z': Writeln('Символ ',c,'- это прописная латинская буква');
  'a'..'z': Writeln('Символ ',c,'- это строчная латинская буква');
  'А'..'Я','Ё': Writeln('Символ ',c,'- это прописная русская буква');
  'а'..'я','ё': Writeln('Символ ',c,'- это строчная русская буква');
  '0'..'9': Writeln('Символ ',c,'- это цифра');
  else Writeln('Символ ',c,'- это специальный знак')
  end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?