В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
daniel9876
daniel9876
06.01.2020 02:08 •  Информатика

Написать программу с использованием цикла while. через каждые пять секунд каждая амеба делиться на две амебы. изначально была 1 амеба. сколько амеб будет через n секунд? проверить решение для 10, 25, 72 секунд.

Ответ:
славка23
славка23
13.08.2020 17:55
Это просто! Вот решение:

Var n,a,time:integer;
Begin
Readln(n);
a:=1;time:=0;
while time<n do begin
if frac(time/5)=0 then a:=a*2;
time:=time+1;            //èëè âìåñòî ýòîãî " Inc(time); "
End;
Writeln(a);
End.

И результаты проверки:
10 секунд: 4 амёбы
25 секунд: 32 амёбы
72 секунды: 32768 амёбы
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?