В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ольга2224
ольга2224
16.12.2020 14:24 •  Информатика

Написать программу на pascalabc создать программу: "вводится n чисел. найти среднее арифметическое всех нечетных, кратных 3 чисел.

Ответ:
katyaden2
katyaden2
21.09.2020 12:23
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
begin
  var n:=ReadInteger('n=');
  var s:=0;
  var k:=0;
  var m:integer;
  for var i:=1 to n do begin
    Read(m);
    if Odd(m) and (m mod 3 = 0) then begin
      s+=m; Inc(k)
      end
    end;
  if k>0 then Writeln(s/k)
  else Writeln('Нет чисел, удовлетворяющих условию')
end.

Тестовое решение:
n= 10
6 3 12 15 -9 11 0 14 42 11
3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?