В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
лоро12
лоро12
06.07.2022 13:24 •  Информатика

2. составьте программу, определяющую, на какую букву начинается третье слово в предложении. 3*. составьте программу, определяющую длину последнего слова в предложении. желателно в qbasic

Ответ:
единорог106
единорог106
27.05.2020 15:49

2.

Program Pr1;
uses crt;
var stroka:string;
i,a,b:integer;
Begin
clrscr;
readln(stroka);
b:=1;
if stroka[b]<>' ' then a:=1
else while stroka[b]=' ' do b:=b+1;
for i:=1 to length(stroka) do begin
if (stroka[i]=' ') and (stroka[i+1]<>' ') then a:=a+1;
if a=3 then begin
writeln(stroka[i+1]);
break;
end;
end;
end.

 

Ойтебе в QBasic...извиняй

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?