В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
strong123
strong123
23.09.2020 03:07 •  Информатика

Задан массив из 10 целых чисел. найдите среднее арифметическое всех четных элементов массива. , составьте программу в паскале: )

Ответ:
кирилл2434
кирилл2434
31.07.2020 14:25
Задачка в один оператор)))

// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
begin
  Writeln(ArrRandom(10,1,99).Println.Where(x->x mod 2=0).Average)
end.

Тестовое решение:
96 42 79 85 16 22 50 62 54 40
47.75

"Школьный подход" (видимо, короткому решению у нас не учат)

// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
const
  n=10;
var
  a:array[1..n] of integer;
  i,k,s:integer;
begin
  s:=0;
  k:=0;
  Randomize;
  for i:=1 to n do begin
    a[i]:=Random(99)+1;
    Write(a[i],' ');
    if a[i] mod 2 = 0 then begin
      s:=s+a[i];
      Inc(k)
      end
    end;
  Writeln;
  Writeln(s/k)
end.

Тестовое решение:
22 22 58 41 54 80 71 65 47 99
47.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?