Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
enotzdrt
27.03.2021 20:08 •
Информатика
Задан массив м, состоящий из n целочисленных элементов. упорядочить элементы таким образом, чтобы вначале распологались все нечётные аргументы, а после них все четные
Ответ:
145milana
21.09.2020 10:29
Class ArrayEven{
public static void main(String args[]){
java.util.Scanner in = new java.util.Scanner(System.in); long eArray[] = new long[1];
while((eArray[eArray.length-1] = in.nextLong())!=-1){
long nArray[] = new long[eArray.length+1];
for(int nCell = 0; nCell<eArray.length; nCell++)nArray[nCell]=eArray[nCell];
eArray = nArray;
} eArrayCell:
for(int cCell = 0; cCell<eArray.length-1; cCell++){
if(eArray[cCell]%2==1)continue;
else for(int eCell = cCell+1; eCell<eArray.length-1; eCell++)
if(eArray[eCell]%2==1){
eArray[eArray.length-1]=eArray[cCell];
eArray[cCell]=eArray[eCell];
eArray[eCell]=eArray[eArray.length-1];
continue eArrayCell;
}
break;
}
for(int cCell = 0; cCell<eArray.length-1; cCell++)System.out.print(eArray[cCell]+" ");
}
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Alinwhite
16.11.2021 04:11
Решить .племя обезьяны пишет письма пользуясь 32 символьным алфавитом племя слоны пользуется 64 символьным алфавитом вожди племен обменялись письмами письмо племени обезьяны...
жасик0071
01.01.2022 14:59
Сообщение, составленное с 32-символьного алфавита,содержит 80 символов. другое сообщение, составленное с 64- символьного алфавита, содержит 70 символов. сравните обьемы информации,...
SobolevaAlina
01.01.2022 14:59
Определите, есть ли в массиве числа от 3 до 7. укажите их номер....
Адриана111111111
02.10.2020 00:18
Скласти діалог на тему карантин це не канікули 10 реплік плі...
Mmmmmmamba
02.08.2020 14:23
Территории, имеющие ледники: Варианты ответов Исландия Гималаи Цейлон Памир Аравийский полуостров...
реа200
14.09.2021 12:17
Образуй притяжательные прилагательные в форме м.р. ед.ч. Им.п., используя суффиксы -ин, -ов, -й(ий). а) внучка- б) птица- в) князь...
Solomina2
14.09.2021 12:17
«Верно или ложно?» Прочитайте! Если утверждение верное, то запишите букву в , если ложное букву л напротив номера утверждения (переписывать утверждения не нужно) 1. Единицы...
khodha
08.10.2021 09:20
Напишите примеры благотворительности в современной России...
MrNikita5
08.10.2021 09:20
Сообщение на тему - Московское княжество в первой половине 15 в. (7-10 предложений предложений...
LinaPozniak08
14.09.2021 12:17
Напишите программу, которая определяет произведение ряда n!=1•2•3•…•n, где n – натуральное число. В программе используйте цикл с параметром....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
public static void main(String args[]){
java.util.Scanner in = new java.util.Scanner(System.in); long eArray[] = new long[1];
while((eArray[eArray.length-1] = in.nextLong())!=-1){
long nArray[] = new long[eArray.length+1];
for(int nCell = 0; nCell<eArray.length; nCell++)nArray[nCell]=eArray[nCell];
eArray = nArray;
} eArrayCell:
for(int cCell = 0; cCell<eArray.length-1; cCell++){
if(eArray[cCell]%2==1)continue;
else for(int eCell = cCell+1; eCell<eArray.length-1; eCell++)
if(eArray[eCell]%2==1){
eArray[eArray.length-1]=eArray[cCell];
eArray[cCell]=eArray[eCell];
eArray[eCell]=eArray[eArray.length-1];
continue eArrayCell;
}
break;
}
for(int cCell = 0; cCell<eArray.length-1; cCell++)System.out.print(eArray[cCell]+" ");
}
}