В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
вера546
вера546
10.08.2020 01:50 •  Информатика

Составьте программу в паскаль. в кафе лимонад по n руб. и мороженое по t руб. составьте алгоритм, который сообщает "возьмите сдачу", "доплатите еще" или " за покупку" при оплате покупателем за m лимонадов и r мороженых денег в размере s руб.

Ответ:
warfacepolina2
warfacepolina2
21.09.2020 10:17
Var n,t,m,r,s,raznica:real;
begin
    writeln('Цена лимонада?');
    readln(n);
    writeln('Цена мороженого?');
    readln(t);
    writeln('Сколько покупаете лимонада?');
    readln(m);
    writeln('Сколько покупаете мороженого?');
    readln(r);
    writeln('Сколько даёте денег?');
    readln(s);
    raznica:=s-(n*m+t*r);
за покупку!') else if raznica>0 then writeln('Возьмите сдачу: ', raznica, ' рублей') else writeln('Доплатите ещё ', abs(raznica), ' рублей');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?