В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Grazhdankin
Grazhdankin
24.04.2020 15:28 •  Информатика

Составьте программу , которая считывает с клавиатуры n чисел и находит сумму и среднее арифметическое значение нечетных чисел

Ответ:
inna755780987
inna755780987
21.09.2020 10:21
Объявим нужные переменные
Нам потребуется sum(сумма), average(ср. арифм), i(для цикла), n(кол-во чисел), x(введенное значение), count(счетчик нечетных)
Присваиваем переменной n(кол-во чисел) нужное значение.
Обнуляем summ и count
Организовываем ввод чисел с клавиатуры через цикл от 0 до n
Внутри цикла делаем проверку на четность, примерно так:
if x mod 2 = 1 then (mod 2 обозначает остаток от деление на 2)
А здесь увеличиваем переменную sum = sum + x
И счетчик count = count + 1

Теперь после того как все итерации пройдены
Переменная sum хранит значение суммы нечетных чисел.
А переменную average надо разделить на count. average = average / count
Так мы получим ср. арифметическое для всех нечетных чисел.

Выводим значение sum и average.
0,0(0 оценок)
Ответ:
ыаррауцйу
ыаррауцйу
21.09.2020 10:21
//PascalABC
//NaaMan
var
    N, sum, num, i : integer;
    A : array[1..10000] of integer;
    SA : real;
begin
    write('Укажите, сколько будет чисел > ');
    readln(N);
    write('Вводите элементы массива > ');
    // Обнуляем сумму
    sum := 0;
    // и количество искомых элементов
    num := 0;
    // Ввод элементов массива с одновременным подсчетом
    for i := 1 to N do begin
        // Ввод
        readln(A[i]);
        write('Ещё > ');
        // Если введённое нечётное, то
        if A[i] mod 2 = 1 then begin
            // добавляем к сумме
            sum := sum + A[i];
            // и считаем их количество
            num := num + 1;
        end;
        // Это среднее арифметическое
        SA := sum / num;
    end;
       
    writeln('Сумма элементов ', sum);
    writeln('Среднее арифметическое ', SA);
end.

Составьте программу , которая считывает с клавиатуры n чисел и находит сумму и среднее арифметическо
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?