В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vindrosel
Vindrosel
12.03.2021 14:11 •  Информатика

Программа в паскале. 3 натуральных числа,если сумма первых двух больше нуля,определите максимальное число,в ином случае вычислите среднее арифметическое.

Ответ:
Яринка05
Яринка05
03.10.2020 05:39
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
var
  a,b,c:integer;
  r:real;
begin
  Writeln('Введите три числа: '); Read(a,b,c);
  if a+b>0 then begin
    r:=a;
    if b>r then r:=b;
    if c>r then r:=c
    end
  else r:=(a+b+c)/3;
  Writeln('Результат равен ',r)
end.

Тестовые решения:
Введите три числа:
-5 8 11
Результат равен 11

Введите три числа:
-3 -6 8
Результат равен -0.333333333333333
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?