В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
po4emy228
po4emy228
15.08.2020 22:08 •  Информатика

Составьте программу вычисления 1+2+4+8++2(в 10 степени)

Ответ:
123фидан321
123фидан321
21.09.2020 07:58
Pascal abc;
var a,b,sum:longint;
begin
b:=1;
for a:=0 to 10 do begin
sum:=sum+b;
b:=b*2;
end;
writeln('сумма чисел от 2^0 до 2^10 sum=',sum);
end.

С++;
#include <iostream>
using namespace std;
int main()
{
  int sum=0,b=1;
  for(int a=0;a<=10;a++)
  {
sum=sum+b;
b=b*2;
  }
  cout<<"сумма чисел от 2^0 до 2^10 sum = "<< sum;
 return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?