В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rot3
rot3
14.12.2022 02:25 •  Информатика

Написать программу, в которой массив из 20 элементов заполняется случайными числами и вычисляется произведение всех элементов массива.

Ответ:
sinjay
sinjay
13.08.2020 17:28
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var a:=ArrRandom(20,-15,25); a.Println;
  var p:BigInteger:=1;
  foreach var x in a do p*=x;
  Writeln('Произведение элементов равно ',p)
end.

Тестовое решение:
-3 5 8 -14 10 19 18 -15 15 -13 22 9 7 20 -12 6 6 -8 -3 -8
Произведение элементов равно 38640208365158400000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?