В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
shahmir2406
shahmir2406
02.11.2020 09:17 •  Информатика

Написать программу, которая вводит три числа – а, в, с и распечатывает только те из них, которые кратны 3 и оканчиваются на 5. если таких чисел нет, напечатать слово нет. например, если введены числа: 15, 25, 45, то распечатаны должны быть числа 15 и 45. если введены числа 15, 60, 25, то распечатано должно быть только число 15. если введены числа 14, 25, 60, то должно быть напечатано слово нет.

Ответ:
Kodan123
Kodan123
03.10.2020 04:55
Var a,b,c:integer;
k:boolean;
begin
readln(a);
readln(b);
readln(c);
k:=false;
if (a mod 3=0) and (a mod 10=5) then
 begin;
 writeln(a);
 k:=true;
 end;
if (b mod 3=0) and (b mod 10=5) then
 begin;
 writeln(b);
 k:=true;
 end;
if (c mod 3=0) and (c mod 10=5) then
 begin;
 k:=true;
 writeln(c);
 end;
if k=false then writeln('НЕТ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?