Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
alisherpitbul
30.05.2020 19:13 •
Информатика
Составить программу с цикла repeat. составить программу выводящую и суммирующую любое количество целых чисел если введено 999 о на экран выводится результат суммирования.
Ответ:
raisabarsegyan
07.08.2020 07:08
На языке Java. Программа складывает и отрицательные и положительные числа.
class SumNum{
public static void main(String args[]){
try{
long sumNum=0,numSum=new Long(new java.io.BufferedReader(new java.io.InputStreamReader(System.in)).readLine());
do sumNum+=numSum;while((numSum>0?--numSum:++numSum)!=0);System.out.print("Результат "+sumNum);
}catch(java.io.IOException io){
System.out.println(" - Ошибка ввода!\n"); main(null);
}catch(NumberFormatException nf){
System.out.println(" - Введите целочисленное значение!\n"); main(null);
}
}
}
0,0
(0 оценок)
Популярные вопросы: Информатика
kreker128
23.07.2020 00:43
Еллі опинилася на роздоріжжі: одна дорога веде до міста правдолюбів а інша до міста брехунів. правдолюби завжди кажуть правду, а брехуни- неправду. еллі зупинила подорожнього...
SaminaR
01.06.2022 03:15
Есть еще один ответ токо не поместился он...
klimantovich72
17.03.2022 22:45
14 Робот находится в верхней клетке узкого вертикального коридора. Ширина коридора – одна клетка, длина коридора может быть произвольной. Напишите для Робота алгоритм, закрашивающий...
afsanka98
28.03.2023 13:08
Запиши число 14582 в развёрнутом виде, начиная со старшего разряда...
жорж78
13.02.2023 13:57
Задача 4 Вася отправляет шифровки своей сестре — юной разведчице Соне. Ей очень нравится, когда шифровка выглядит красиво. В этот раз Вася зашифровал своё послание в n букв...
avamasha
02.06.2022 07:04
Придумай коротку фантастичну історію про чарівника...
mazeke78
18.06.2021 18:55
Элвин разрезал лист бумаги прямоугольной формы с размерами 7,2 см и 1,8 см на части, которые затем хочет скрепить в форме квадрата. А) Скольким сантиметрам будет равна сторона...
Leo100Danik1
09.02.2023 18:01
Почему при менее глубоком посеве крупных семян, им не хватит влаги. Они же всё равно будут полугать воду...
mailkostya1992
23.11.2021 11:22
Выпишите слово.в котором правописание ПРИСТАВКИ зависит от глухости -звонкости последующего согласного: в эти безрадостные дни непогожие дни в доме было особенно уютно .стол...
1Booooooooooom1
09.06.2023 07:00
Как быстро и легко умереть?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
class SumNum{
public static void main(String args[]){
try{
long sumNum=0,numSum=new Long(new java.io.BufferedReader(new java.io.InputStreamReader(System.in)).readLine());
do sumNum+=numSum;while((numSum>0?--numSum:++numSum)!=0);System.out.print("Результат "+sumNum);
}catch(java.io.IOException io){
System.out.println(" - Ошибка ввода!\n"); main(null);
}catch(NumberFormatException nf){
System.out.println(" - Введите целочисленное значение!\n"); main(null);
}
}
}