В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
уютка
уютка
14.03.2023 15:17 •  Информатика

Дан целочисленный массив из 20 элементов. элементы массива могут быть целыми числами от -1000 до 1000. найдите минимальный элемент среди положительных, делящихся на 3 и нечетных

Ответ:
Danila12312
Danila12312
20.09.2020 16:02
Uses crt;
const n=20;
var i,min:integer;
a:array [1..n]   of integer;
begin
randomize;
for i:=1 to n do
 a[i]:= random(2001)-1000; {read (a[i])}{ручной ввод чисел}
min:=1001;
for i:=1 to n   do
if (a[i]>0)  and (a[i]mod 3=0) and (odd(a[i])) and (a[i]<min) then
 min:=a[i];
if min<>1001 then
 writeln(min)
else
  writeln('нет чисел удовлетворяющих заданному условию');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?