В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
okuprie
okuprie
24.01.2021 08:14 •  Информатика

Даны два массива из n целых чисел.найти наименьший среди тех чисел первого массива,который не содержится во втором. напишите программу в паскале

Ответ:
igorbaburin67
igorbaburin67
03.10.2020 03:53
// PascalABC.NET 3.0, сборка 1128
begin
  var n:=ReadInteger('n=');
  Writeln('Первый массив:');
  var a:=ArrRandom(n,1,50).Println(',');
  Writeln('Второй массив:');
  var b:=ArrRandom(n,1,50).Println(',');
  Writeln('Минимальное значение, отсутствующее во втором массиве: ',
       a.OrderBy(x->x).Except(b.OrderBy(x->x)).Take(1))
end.

Тестовое решение:
n= 20
Первый массив:
18,1,4,1,22,14,34,18,50,9,27,41,26,11,8,34,7,35,34,33
Второй массив:
7,19,3,8,26,30,50,46,33,20,1,3,9,4,34,42,1,7,46,34
Минимальное значение, отсутствующее во втором массиве: [11]
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?