Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Ксюнька1801
10.04.2023 22:24 •
Информатика
Дан одномерный целочисленный массив состоящий из 10 элементов составьте программу определения значемния суммы наибольшего и наименьшего элементов этого массива массив заполнить любым
Ответ:
ания7
03.10.2020 03:17
// PascalABC.NET 3.0, сборка 1111
begin
var a:=ArrRandom(10,-15,25);
Write('Исходный массив: '); a.Println(',');
Writeln('Сумма min+max=',a.Min+a.Max)
end.
Тестовое решение:
Исходный массив: -8,-6,15,16,17,21,9,10,-15,19
Сумма min+max=6
0,0
(0 оценок)
Ответ:
Nicktat
03.10.2020 03:17
Program Project1;
var i, max, min:integer; mass:array [0..9] of integer;
begin
randomize;
for i:=1 to 9 do mass[i]:=Random(100);
max:=0;
min:=100;
for i:=1 to 9 do begin
if max<mass[i] then max:=mass[i];
if min>mass[i] then min:=mass[i];
end;
writeln('max: ', max);
writeln('min: ', min);
writeln('max + min = ', max+min);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Аранида
07.10.2021 04:29
Паскаль, не могу разобраться в чем ошибка. в общем напишите программу создать, нетекстовый файл, который содержит информацию о телефонах сотрудников учреждения (фамилия,...
asdsssssssssss124
11.06.2021 09:03
Что будет нарисовано посте выполнения чертежником алгоритма: использовать чертежник алг. нач. * поднять перо * сместиться в точку (2; 4) * опустить перо * сместиться...
JackKalibr
02.04.2023 14:11
Допустим что тело цикла должно содержать два оператора. какие из операторов правильные, какие нет и почему? a) for i: =12 to 15 do s: =s+i; б) for a: =30 to 20 do...
mpotlov747
21.04.2023 13:07
Основопологающим в смене поколений эвм является?...
MrRobik
31.08.2020 17:12
(Python) Напишите программу, которая считает три числа и большее из них уменьшит на 5. Формат входных данных Вводятся три различных целых числа a, b, c (230≤a,b,c≤230−1)....
vovova2020
10.03.2022 10:32
В игре Русское лото» из мешка случайным образом выбираются бочонки, на каждом из которых написано число от 1 до 90. Напишите 5 программу, которая выводит наугад первые...
lllaasaw
26.01.2023 04:47
Брату задали дз по информатике, очень надо)) буду очень благодарна...
ressoli442
16.12.2020 03:08
1. Что является модификацией операционной системы Windows7. 2.какое приложение является прикладной программой? 3. Какие программы предназначаются для создания небольших...
andrekonushew
22.04.2020 11:01
Якого значення набуде зміна x після виконання даного коду x=3 x+=2 Варіанти відповідей 5 1 2 3 6...
acre5422какаха
27.09.2022 14:41
Запишите содержимое (в шестнадцатеричной системе) регистра DL, полученное в результате выполнения следующих операторов ассемблера: MOV DL, 0F1h MOV CL, 3 SHR DL,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
var a:=ArrRandom(10,-15,25);
Write('Исходный массив: '); a.Println(',');
Writeln('Сумма min+max=',a.Min+a.Max)
end.
Тестовое решение:
Исходный массив: -8,-6,15,16,17,21,9,10,-15,19
Сумма min+max=6
var i, max, min:integer; mass:array [0..9] of integer;
begin
randomize;
for i:=1 to 9 do mass[i]:=Random(100);
max:=0;
min:=100;
for i:=1 to 9 do begin
if max<mass[i] then max:=mass[i];
if min>mass[i] then min:=mass[i];
end;
writeln('max: ', max);
writeln('min: ', min);
writeln('max + min = ', max+min);
end.