В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Акерке2006
Акерке2006
27.01.2020 13:30 •  Информатика

Напишите программу, которая находит среди элементов массива, состоящего из n элементов, наименьший элемент и его порядковый номер.

Ответ:
yestarday23
yestarday23
03.10.2020 03:08
Var
a:array[1..1000000]of integer;
i,min,n,c:integer;
   begin
      readln(n);
      for i:=1 to n do
      begin
       read(a[i]);
         if i = 1 then
         min:=a[i];
       if a[i]<min then
        begin
       min:=min+a[i] ;
       a[i]:=min - a[i];
       min:=min - a[i];
         c:=i;
         end;
      end;
    writeln('a[',c,']=',min);
    end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?